Skip to main content
SVRS MindTouch

ntouch Mobile Android requirements

Android Operating System Devices

  • Android telephone or tablet must support 4.0.4 (Ice Cream Sandwich) or higher.
    • For best video quality, we recommend using a device that supports Android 5.0 (Lollipop) or higher. Lollipop's support for hardware encoding and decoding allows for much better frame rates with less power consumption versus earlier releases. 
  • Android telephone or tablet must support the Google Play Store.
  • Not supported at this time:
    • Chromebook or Chrome OS.
    • Phone or tablet with rotating camera.

Amazon Kindle Fire OS Devices

  • Amazon Kindle Fire OS devices must support the Amazon Appstore for Android.
  • All Amazon Fire tablets with front-facing camera should work, but we recommend using one of the latest model tablets (i.e, the 2015/2016 versions) because these models contain faster hardware and because the Fire OS 5.x.x.x is based on Android 5 (Lollipop).