Skip to main content
SVRS MindTouch

ntouch Mobile iOS requirements

Operating System Requirements

  • Minimum operating system is iOS 10.0
    • For older iOS devices that are not able to upgrade to 10.0, ntouch Mobile version will remain at 8.6.155.
  • Suggested minimum operating system is 11.

Hardware Requirements

  • Minimum device is an iPhone 5 or iPad Air. 
  • Suggested minimum device is an iPhone 5.
  • Recommended device is an iPhone X.